0

Fortigate: Cómo hacer trunking

Difunde No Solo Hacking!

Muchos de vosotros ya tenéis experiencia en dispositivos de red, tanto de capa dos como capa tres. Pero para los que no, deciros que la capacidad de tener puertos físicos en un dispositivo de capa dos, como puede ser un Switch es muuuuucho más barato que en uno de capa 3, como el router o firewall.

En los switches podemos tneer desde 8 puertos hasta 48 por dispositivo a un precio muy razonable. En routers o firewalls solemos manejar hasta 10 (normalmente). Por lo que nos vemos obligados a tirar de trunk en lugar de usar un purto físico para VLAN. Por lo que vamos a aprender a hacer trunking en firewalls de Fortinet, Fortigate.

Laboratorio

Requisitos para el LAB

  • Crear VLANs en Firewall y Switch
    • VLAN20 usuarios
    • VLAN30 HR
  • Configuraciones:
    • Firewall:
      • Crear VLANs y DHCP en ellas.
      • Asignar VLANs al puerto 1
    • Switch:
      • Trunk VLAN 20 y 30 en uplink al Firewall
      • e0/1 VLAN20
      • e0/2 VLAN30

Configuraciones

Configuración en el firewal:

edit "port1"
        set vdom "root"
        set mode dhcp
        set allowaccess ping https ssh fgfm
        set type physical
        set snmp-index 1
next

edit "VLAN20"
        set vdom "root"
        set ip 10.10.100.1 255.255.255.0
        set allowaccess ping https fgfm http
        set device-identification enable
        set role lan
        set snmp-index 11
        set interface "port1"
        set vlanid 20
    next
    edit "VLAN30"
        set vdom "root"
        set ip 10.10.200.1 255.255.255.0
        set allowaccess ping https fgfm http
        set device-identification enable
        set role lan
        set snmp-index 12
        set interface "port1"
        set vlanid 30
    next
end

config system dhcp server
        edit 2
        set dns-service default
        set default-gateway 10.10.100.1
        set netmask 255.255.255.0
        set interface "VLAN30"
        config ip-range
            edit 1
                set start-ip 10.10.100.2
                set end-ip 10.10.100.254
            next
        end
    next
    edit 3
        set dns-service default
        set default-gateway 10.10.200.1
        set netmask 255.255.255.0
        set interface "VLAN20"
        config ip-range
            edit 1
                set start-ip 10.10.200.2
                set end-ip 10.10.200.254
            next
        end
    next
end

Configuraciones para el switch:

interface Ethernet0/0
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 20,30
 switchport mode trunk
 duplex auto
!
interface Ethernet0/1
 switchport access vlan 20
 switchport mode access
 duplex auto
!
interface Ethernet0/2
 switchport access vlan 30
 switchport mode access
 duplex auto
!

Archivos

Vídeo


Difunde No Solo Hacking!

Carlos Melantuche

Leave a Reply

Your email address will not be published. Required fields are marked *

72 ÷ 18 =